Visual Studio Community 2015 Crashing on Startup

Since yesterday I have been having a very strange error in Visual Studio Community 2015 where as soon as I open a solution VS crashes with no error. Now the only thing that has changed since yesterday was that I installed a large number of Windows updates that had been waiting for probably several months! I checked my installed updates but found nothing directly related to VS. I did find an update that made changes to .net but was unsure if this was related. The error I received was as follows;

Luckily, VS gave me the option to debug itself which helpfully shed a bit more light on the situation (although it had me chasing something that wasn’t the issue..). Once opened in the debugger, I received the following exception;

Notice the error is in a Xamarin extension? Phew, I thought, I’ll just uninstall Xamarin and hopefully everything will go back to normal. Obviously, that wasn’t the case! I still got the same crash loading the solution but now when debugging the exception was different;

System.IO.FileNotFoundException was unhandled Message: An unhandled exception of type ‘System.IO.FileNotFoundException’ occurred in Microsoft.CodeAnalysis.Workspaces.dll Additional information: Could not load file or assembly ‘System.Resources.ResourceManager, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’ or one of its dependencies. The system cannot find the file specified.

Now this exception is a bit more interesting. I thought I’d have a look on Google to see if anyone else had had this problem lately. Sure enough, I found a couple of posts of users with the same issue on both Stack Overflow and Microsoft Connect. The only problem was that there was no solution on either site! So after running numerous tools such as the launching Visual Studio in safe mode and running the .net repair tool I decided it was time to try a reinstall.. But, you guessed it, after a couple of hours waiting I still have the exact same error once I tried to load a solution!

If someone does by chance find a solution, please let me know!

Leave a Reply

Your email address will not be published. Required fields are marked *